Ошибка при отправлении своего сообщения на форум

Автор POMAH, 09.06.07, 04:17:01

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

POMAH

Прошу администратора рассмотреть данную ошибку: происходит всегда при отправке сообщения, при нажатии "Назад" показывается предупреждение о поступлении нового сообщения, при чем моего!!!

Администратор

Если я правильно понимаю Вашу запутанную формулировку, это не ошибка, а корректная работа.

Если я понимаю неправильно, переформулируйте замечание так, чтобы его можно было понять правильно   :)

POMAH

09.06.07, 09:26:12 #2 Последнее редактирование: 09.06.07, 09:58:13 от POMAH
ПРОБУЮ!

Пишу сейчас ответ, нажимаю "Отправить" мне в окне вылетает сообщение "Невозможно отобразить страницу...". Жму "Назад" - получаю предупреждение о написании ответа в топик (это мой ответ)...
Т.е так должно быть ??? :%:
Раньше такого не было... Жму "Отправить" и попадаю в топик

Администратор

09.06.07, 09:42:42 #3 Последнее редактирование: 09.06.07, 10:08:27 от Администратор
Цитата: POMAH от 09.06.07, 09:26:12
нажимаю "Отправить" мне в окне вылетает сообщение "Невозможно отобразить страницу...".

Это ошибка. Но скорее всего, она локально у Вас проявляется. Не меняли настройки браузера в последнее время? Связь с интернетиком стабильная?

Цитата: POMAH
Жму "Назад" - получаю предупреждение о написании ответа в топик (это мой ответ)...
Т.е так должно быть ??? :%:

Да, вот это как раз правильно.
Смотрите, что происходит. Вы пишете сообщение, находясь на некой странице [1]. Как только Вы нажимете кнопку Отправить -- Вы неявным образом попадаете на следующую страницу [2] (в этом можно убедиться, если в момент нажатия кнопки Отправить смотреть на адресную строку в браузере -- адрес в ней заменится на другой). На этой странице [2] отрабатывает мини-программа, которая вставляет Ваш ответ в базу данных Форума на веб-сервере, а затем переправляет Вас на следующую страницу [3] -- страницу показа вновь созданного сообщения (в этом тоже можно убедиться, если в момент нажатия кнопки Отправить смотреть на адресную строку в браузере).
У Вас происходит какая-то ошибка при автоматическом переходе со страницы [2] на страницу [3] (ну например, банально обрывается связь с интернетом). В этом случае Ваше сообщение уже отправлено в базу данных Форума (страница [2] сделала свое дело), но посмотреть его Вы не можете (страница [3] не открывается).
Вы нажимаете кнопку Назад. И вновь оказываетесь на странице [2], которая пытается повторно отправить Ваше сообщение в Форум. Но т.к. оно уже там есть, Вы получаете соответствующее предупреждение -- точно так же, как Вы получили бы его, если бы за время написания Вашего поста в топик уже ответил кто-то другой.

Добавление: Когда получили ошибку "Невозможно отобразить страницу...", надо не "Назад" нажимать, а F5 (обновление страницы). Тем самым Вы повторно попытаетесь загрузить страницу [3] (страницу просмотра отправленного сообщения), не возвращаясь к его отправке. 

Цитировать
Раньше такого не было... Жму "Отправить" и попадаю в топик

Я надеюсь, у всех отправка сообщений работает именно так. Пожалуйста, подтвердите нормальную отправку сообщений или подтвердите ошибку, проявляющуюся у Романа.

Pav

У меня работает все нормально, на момент отправки этого сообщения.

POMAH

Цитата: Администратор от 09.06.07, 09:42:42
Это ошибка. Но скорее всего, она локально у Вас проявляется. Не меняли настройки браузера в последнее время? Связь с интернетиком стабильная?


С интерником все нормально.  :) Какие настройки браузера могут повлиять на работу отправки сообщений?

Цитата: Администратор от 09.06.07, 09:42:42
Добавление: Когда получили ошибку "Невозможно отобразить страницу...", надо не "Назад" нажимать, а F5 (обновление страницы). Тем самым Вы повторно попытаетесь загрузить страницу [3] (страницу просмотра отправленного сообщения), не возвращаясь к его отправке. 


СПАСИБО за информацию! Нажимал и "F5" - не помагает, приходится "пятится назад"... :(

Администратор

Честно говоря, я не знаю точно, что может повлиять.
Предполагаю, например, что кеширование страниц (но это именно гипотеза).
Т.к. у остальных возврат к отправленному сообщению работает нормально -- сам «движок» Форума явно в порядке.
Посоветуйтесь со своим системным администратором или службой техподдержки провайдера. Может, они что-то полезное посоветуют...

ingeneer

Проблема такого свойства.
При попытке отправить сообщение едва ли не в каждом втором случае получаю следующее сообщение (см. вложение). Причём с полной ответственностью заявляю: ничего из перечисленного я не совершал. Нажимаю Backspase (или кнопку На предыдущую страницу браузера) и таки попадаю на предыдущую страницу. К счастью, текст сообщения сохраняется в окне набора, но при попытке его отправить, снова получаю то же сообщение. Однако если получения сообщения об ошибке вернуться назад, обновить страницу (F5) и попробовать снова отправить сообщение, то сообщение отправляется.
Браузер Mozilla Firefox 2.0.0.12, Однако и в IE 6.0 (когда я ещё им пользовался) была такая же проблема.
Прошу разобраться :)