Привязка в сборке к элементам массива

Автор Volod, 13.11.06, 11:36:35

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

Volod

В сборке есть элемент созданный как листовой металл. Этот элемент размножен как линейный массив.
При попытке с помощью сопряжений привязать к последнему элементу массива другой элемент ничего не получается, на элементе массива не выделяются грани, кромки.
Это глюк, компас не может этого еще делать или я что-то неправильно делаю?

Компас 8+СП2

Leo


VV

Это не глюк, это судьба...

Сопряжения к элементам массива не работают.

Alisa

Не очень переживайте. Привязкой к элементам массива, как показала практика SW, нужно пользоваться осторожно. А лучше, по возможности, не пользоваться совсем. Массив нельзя редактировать. Может получиться такое, что потом полдня ошибки в сопряжениях будете выгребать..

POMAH

Сделали хотя бы, чтобы элементы массива не перемещались, как в SW - если оригинал определен в сборке, то и элементы массива определены... :um: Кстати SW предупреждает в сообщениях, когда элемент сборки определен или фиксирован... :um: В этом плане очень удобно :), а в сопряжениях с элементами массива не вижу необходимости - сделаете или не сделаете, всё равно. :sun:

Илья Муромец

Возможность привязки к элементам массива очень нужна. У меня металлоконструкция состоит из типовых элементов. Проще всего было бы выполнить массивом, но поскольку в итоге надо выполнять привязку к массиву элемента приходится изрядно попотеть в поиске альтернативных вариантов.

VIO

06.01.15, 06:54:09 #6 Последнее редактирование: 06.01.15, 07:22:23 от VIO
Цитата: Илья Муромец от 06.01.15, 06:09:21
Возможность привязки к элементам массива очень нужна.

Так она есть, начиная с 12-ой или 13-ой версии.
Разговор, судя по дате поста, идет о 8-ой  версии, там этого не было.
Цитата: Volod от 13.11.06, 11:36:35
Компас 8+СП2

А у Вас какая версия?

Илья Муромец

Версия 15. До этого пробовал в 14. Всех сопряжений не пробовал, но вот совпадение или на расстоянии не работают. Т. е. выбор поверхностей осуществляется, все нормально, но по завершении команды связь с ошибкой "не найдена поверхность"

VIO


GenTAPo

Уже с 10-й версии есть привязки к элементам массива. У нас в 10-ке до сих пор работают.

Илья Муромец

Не спорю, есть, но часто не срабатывает.

GenTAPo

С этим согласен. И бесит, что не поймёшь, чего же тебе надо! Для эксперимента сделаешь привязку к этой же детали, но с другой стороны, это пожалуйста. Но в последних версиях я этого пока не замечал.