На клиентах - все ок, на сервере - демо режим

Автор BIV, 29.03.06, 14:02:17

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

BIV

Имеется сеть из 15 компьютеров (OS Win2k) и "сервера" (OS WinXPPro).
Ключик (LPT) установлен на сервере и расчитан на 20 лицензий.
Менеджер (v8.20) работает в режиме службы. с настройками (nhsrv.ini):

[NHS_SERVER]
[NHS_IP]
NHS_USE_UDP = enabled  
NHS_USE_TCP = enabled

[NHS_NETBIOS]
NHS_USE_NETBIOS = disabled

[NHS_IPX]
NHS_USE_IPX = disabled

Настройки клиентов (NetHASP.Ini):
[NH_COMMON]
NH_TCPIP=Enabled
[NH_TCPIP]
NH_TCPIP_METHOD=TCP
NH_USE_BROADCAST=Disabled
NH_SERVER_ADDR=10.22.210.10

Суть проблемы:
Клиенты работают нормально! А клиент на сервере работать отказывается (Деморежим)!
Монитор показывает, что ВСЕ клиенты подключились к ключу, включая и тот, что с сервера запускается!

В чем может быть дело?


Andy

Такая проблема, помню, была с 5.11 или даже раньше...
попробуйте LM 8.07

Hик

Цитата: BIV от 29.03.06, 14:02:17
Имеется сеть из 15 компьютеров (OS Win2k) и "сервера" (OS WinXPPro).
Ключик (LPT) установлен на сервере и расчитан на 20 лицензий.

Какая версия Компас?

Chertenok

Попробуйте подкорректировать файл nethasp.ini

Запись должна будет выглядеть следующим образом:

[NH_COMMON]
NH_TCPIP=Enabled
[NH_TCPIP]
NH_TCPIP_METHOD=UDP
NH_USE_BROADCAST=Disabled
NH_SERVER_ADDR=127.0.0.1

Должно помочь.

BIV

2Andy: пока не пробывал, но у меня сомнения, что будут изменения.
2Chertenok: не помогло.

Cовсем забыл указать версию: "KOMPAS-3D V7 Plus"

Да и еще один момент (так, к слову) - в настройках для клиентов указан протокол tcp, однако менеджер показывает, что все подключены по UDP, так что разницы от переключения на UDP не должно быть.

Andy

30.03.06, 13:36:50 #5 Последнее редактирование: 30.03.06, 13:48:53 от Andy
Цитата: BIV от 30.03.06, 12:57:07
Да и еще один момент (так, к слову) - в настройках для клиентов указан протокол tcp, однако менеджер показывает, что все подключены по UDP, так что разницы от переключения на UDP не должно быть.

Это по большому счету всеравно в любом случае используенся IP портокол
для проверки можно сделать
NHS_USE_UDP = Disanabled
А LM 8.07 всетаки попробуйте...
вообще то у нас 7+ с сетевым ключем на сервере работает и LM 8.20
Да, на сервере в LM включен протокол NetBIOS

Вот еще что, проверьте, работает ли на сервере компас с выключеным  LM cервисом...

И проверьте драйвер ключа, на сервере. Должен  быть V 4.95