Проблема с построением крепежного соединения

Автор solarscream, 24.10.22, 21:57:32

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

solarscream

24.10.22, 21:57:32 Последнее редактирование: 24.10.22, 22:25:31 от solarscream Причина: Дополнено P.S.
Уважаемые знатоки, прошу помощи!

КОМПАС-3D v20.0.12.3193 (64-разрядная версия).

При построении 3D-модели болтового соединения возникает следующая проблема: КОМПАС некорректно рассчитывает расстояние между опорными плоскостями соединения.
Фактически расстояние выдержано 71 мм (как и требуется).
При построении соединения (после назначения опорных поверхностей и отверстия) КОМПАС автоматически указывает расстояние между опорными поверхностями 69,5 мм. При попытке переназначить расстояние вручную на 71 мм (символ квадратного корня справа от строки ввода расстояния) КОМПАС предупреждает о потере опорных плоскостей и затем снова требует их указать, после чего снова происходит автоматический пересчет расстояния на 69,5 мм.

В результате данной проблемы шайба в соединении, расположенная под гайкой, "утопает" в теле фланца, судя по всему, как раз на разность расстояний фактического и расчетного (71-69,5=1,5 мм) - это можно наблюдать на первом скриншоте.

Логика построения, по-моему, верная. Если я не прав, поправьте, пожалуйста.
Прилагаю файлы модели в форматах КОМПАС-3D v19 и v20 (см. вложения Assembly и Assembly v19).

P.S. При автоматическом построении нескольких соединений путем указания всех отверстий создается массив. Но в этом случае добавляется следующий нюанс: шайба под гайкой в первом соединении (являющимся "родителем" создающегося массива) так же "утопает" в теле фланца, но во всех остальных соединения массива шайбы под гайками, наоборот, возвышаются над опорной плоскостью фланца.
P.P.S. При создании массива вручную (по концентрической сетке) обнаружил, что также болты опорными плоскостями своих головок "утопают" в шайбах, расположенных под ними (см. скриншот №5). Теперь точно ничего не понимаю... Это не болты "утопают" в шайбах, а их галтели под головками пересекают кромки отверстий в шайбах, так что технически все норм.
Создал болтовое соединение вручную путем добавления компонентов (стандартных изделий - болт, гайка, шайбы) и созданием массива по концентрической сетке - все расположилось идеально...

Я не могу понять, в чем причина такого поведения программы. Честно говоря, КОМПАС-3D уже реально задолбал: я трачу свое время на разгребание каких-то мелочей, препятствующих нормальному созданию документации. Вручную уже давно все выполнил бы, но понимаю, что нужно выполнять документацию, не нарушая правильный цикл.

Алексей Дубовицкий

Цитата: solarscream от 24.10.22, 21:57:32КОМПАС автоматически указывает расстояние между опорными поверхностями 69,5 мм.
Какой-то локальный глюк. v20.0.12 (БСИ 6.5.6.1523 пакет обновления 1) и v21.0.6 (БСИ 6.5.6.1534 пакет обновления 1), расстояние определяется корректно.

Олеся_Орен

Если у вас некорректно работает вставка болтового соединения, то не проще ли отдельно вставить крепеж из набора. Я, вообще, редко пользуюсь соединениями. Проще вставить стандартные. Их привязать дело нескольких секунд. Ось и совпадение с опорной поверхностью. Больше времени убьете на поиск причины глюка.