MicroReports

Автор Дмитрий22, 09.11.19, 10:04:28

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

Дмитрий22

Начинаю новый бесплатный проект MicroReports. Пока доступна версия 0.13 с поддержкой формирования перечня покупных изделий.
https://yadi.sk/d/lgo6Acxqsnhw5w
От версии 0.12 один из лучших бета-тестеров был не в восторге, немного поработал над стабильностью версии и выкладываю 0.13 на всеобщее обозрение, вдруг кому-нибудь идея понравится.
1. Библиотека позволяет формировать различные перечни по конструкторской документации. При открытой спецификации или сборочном чертеже нажать кнопку соответствующего отчета. Если в спецификации предварительно выбрать объект в разделе «Сборочные единицы», то отчет будет формироваться по выбранному объекту.
2. Для формирования перечней требуется, чтобы имена файлов спецификаций содержали обозначение спецификации. Поиск ведется внутри папки (и во вложенных папках рядом с активной спецификацией). 
3. Поддерживается работа в Компасе v 16 и выше. Реализована нативная поддержка Компаса v 17, 18. Это означает, что кнопки для запуска отчетов располагаются на основной панели Компаса.
4. Инструкция по установке в архиве.

Gdeon

Не находит

Дмитрий22

MS Word установлен на компьютере не ниже 2007?

Gdeon

Цитата: Дмитрий22 от 09.11.19, 16:14:49MS Word установлен на компьютере не ниже 2007?
MS 2010; Winda 2010x64

Дмитрий22

Попробуйте в зайти в настройки MS Word и снять галочку: "Включить защищенный просмотр для файлов из Интернет".
https://mypclife.ru/kak-otklyuchit-zashhishhennyiy-prosmotr-v-microsoft-word/

michmich73

Цитата: Дмитрий22 от 10.11.19, 17:52:27Попробуйте в зайти в настройки MS Word и снять галочку: "Включить защищенный просмотр для файлов из Интернет".
https://mypclife.ru/kak-otklyuchit-zashhishhennyiy-prosmotr-v-microsoft-word/
Привет, Дмитрий!
Вопрос не в настройках ворда. Файл "Перечень покупных изделий.Dot" поврежден и нечитабелен.
Прошу еще раз перевыложить прогу. Предварительно прошу проверить наличие и читабельность файла "Перечень покупных изделий.Dot".

Дмитрий22

Извините, перезалил.
https://yadi.sk/d/BE8COL7cyghPvA

michmich73

Цитата: Дмитрий22 от 20.11.19, 17:36:01Извините, перезалил.
https://yadi.sk/d/BE8COL7cyghPvA
Привет, Дмитрий!
Спасибо за оперативность. Файл шаблона присутствует и читается, библиотека не работает.
В спецификации просто не запускается, а сборочном чертеже выдает сообщение "Не могу получить состав".
Если это о чем-то говорит, то прошу поправить, пожалуйста. Задумка очень интересная и нужная.
Пока в компасе такой реализации ни у кого толком не получилось.

Дмитрий22

Версия Компаса?

michmich73


Дмитрий22

Беру тайм-аут. В 18 переделали спецификацию, возможны проблемы. Буду разбираться.

michmich73

Цитата: Дмитрий22 от 22.11.19, 08:57:56Беру тайм-аут. В 18 переделали спецификацию, возможны проблемы. Буду разбираться.
Это да. Как понял, в будущей 19й специю еще раз переделают.
Спасибо за труды. Как только, то сразу подключусь к тестированию.

VLaD-Sh

Цитата: michmich73 от 22.11.19, 09:50:14Как понял, в будущей 19й специю еще раз переделают.
Не будет вообще.
Будет состав изделия и по нему будем получать различные отчеты

Дмитрий22

Выложил промежуточную версию 0.14 с поддержкой поучения ведомости покупных изделий в Компасе 18. Правда, пока только при работе со спецификациями, в Компасе 16, 17 работает и в чертежах со спецификациями на поле.

https://yadi.sk/d/flQB6Nhf9pClSA

michmich73

Цитата: Дмитрий22 от 25.11.19, 18:26:21Выложил промежуточную версию 0.14 с поддержкой поучения ведомости покупных изделий в Компасе 18. Правда, пока только при работе со спецификациями, в Компасе 16, 17 работает и в чертежах со спецификациями на поле.

https://yadi.sk/d/flQB6Nhf9pClSA
Привет!
К18 вылетает с сообщением "Прекращена работа программы "kompas(x64)"

Дмитрий22

Цитата: michmich73 от 26.11.19, 12:46:57Привет!
К18 вылетает с сообщением "Прекращена работа программы "kompas(x64)"
Я тестировал на 18.1.27, Win 8.
У Вас какие версии ПО?

michmich73

Цитата: Дмитрий22 от 26.11.19, 13:00:18Я тестировал на 18.1.27, Win 8.
У Вас какие версии ПО?
У меня Win 7. Возможно из-за различий в винде 7 и 8.