Оборудование: Кабели и жгуты. Соединители в составе жгута

Автор Igor001, 22.08.19, 13:47:32

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

Igor001

Добрый день, коллеги.

Столкнулся с ситуацией, никак не получается ее понять. Есть библиотека "Оборудование: Кабели и жгуты" для Компас версии 17. Есть видео от АСКОНа на ютьюбе, правда для версии 15. Повторяю все пошагово. Дошел до создания подсборок жгутов. Создал жгут, в Перечне элементов жгута имеются 3 соединителя X1, X2, X3. Возвращаюсь в основное Изделие, запускаю Состав жгута - нет в его составе соединителей. Запускаю Таблицу соединений - та же беда. А в обучающем видео все прекрасно получается. Подскажите, как пройти этот квест? Может, дело в версии библиотеки?

Leo

Была такая бага в версии 17.
Надо сделать так. Открыть Жгут в отдельном окне, запустить команду Позиционные обозначения, увидеть, что все Позиционные есть, на всякий случай нажать ОК.
Потом запустить такую же команду в основной сборке, увидеть, что Позиционное жгута там есть, но все равно нажать ОК.
Потом запустить команду Соединители в блоках/подсборках, выбрать Жгут, и нажать Обновить.

Должно сработать. В следующих релизах исправлено.

Igor001

Цитата: Leo от 22.08.19, 15:03:17
Была такая бага в версии 17.
Надо сделать так. Открыть Жгут в отдельном окне, запустить команду Позиционные обозначения, увидеть, что все Позиционные есть, на всякий случай нажать ОК.
Потом запустить такую же команду в основной сборке, увидеть, что Позиционное жгута там есть, но все равно нажать ОК.
Потом запустить команду Соединители в блоках/подсборках, выбрать Жгут, и нажать Обновить.

Должно сработать. В следующих релизах исправлено.


Спасибо, Leo. Спасибо, добрый человек! Произошло ЧУДО! Сработало. Интересно, что ждет меня в оставшейся половине обучающего видео?))

Igor001

Ну вот и наткнулся на очередное непонимание логики программы.
Создал два жгута. В таблице соединений создал по две трассы на каждый жгут, в трассах сразу назначил провода (по-другому трасса не создается). Нажимаю кнопку "Позиционировать" и тут же получаю окно с алертом, что у меня "Нет присоединительной точки direct, либо контрольной точки key". Нажимаю Ок, повторно появляется такое же окно. То же самое происходит со всеми трассами в Таблице соединений. Полностью проверил все дерево изделия, все точки имеются. Пригласил спеца по 3Д моделированию в Компасе, вдруг я как-то не так расставил эти точки. Ошибок в моем изобразительном искусстве по рисованию точек он не нашел.
Друзья, коллеги, подскажите. Сразу предупрежу - установка последующих версий пока в планах, точно не в этом месяце.

Igor001

Коллеги,
прошло три недели! Неужели никто не знает ответ на мой вопрос? Или хотя бы подскажите, что и где проверить.
очень хочется все-таки пройти этот квест до конца.

Leo

Надо проверить - позиционируются ли блочная и кабельная части с помощью команды Позиционировать ответную часть. Если не стыкуются - значит что-то не так в моделях, их тогда нужно сюда выложить. Если же эта команда работает, то пока пользоваться ею, но сборку все равно приложить сюда