Проблема с Компас 18.1

Автор Ash_wooD, 12.08.19, 06:56:46

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

Ash_wooD

При работе со сборками периодически пропадают все элементы этой сборки (все команды и фон при этом остаются). Масштабирование и вращение сборки не помогают. Помогает команда Показать все (иногда не с первого раза). Но после обновления экран фокусируется на начале координат и не работает команда сдвиг, т.е стрелка появляется но двигать экран нельзя. Вращение также происходит не вокруг той точки где находится курсор а вокруг начала координат. Лечится только если закрыть и заново открыть сборку

YNA

Такая тема уже была и симптомы похожие, но решения кажется так и не нашли. Если у вас есть доступ в СТП лучше обратитесь туда.
У меня нечто похожее происходит, но с боковыми панелями - прорисовка вообще отваливается. Лечится или переключением Дерево-Параметры или перезагрузкой программы, по любому напрягает.
+ Благодарностей: 1

Ash_wooD

Да доступ есть и писать буду конечно, но надеялся, что найдется кто то кто уже сталкивался и вылечил

VIO

12.08.19, 07:27:10 #3 Последнее редактирование: 12.08.19, 07:38:44 от VIO
Такая же проблема существует и в 17-ом Компасе.
После обновления пакета 10-х "Окон" перестают иногда отображаться сборки, на экране её нет, а на вторичном изображении через закладки видно.
Может дрова видюхи может ещё что.
Научился бороться с этим, следующим образом, закрываю не отображаемую сборку, и открываю любой чертеж, фрагмент он отображается полностью.
После запускаю проблемную сборку, и о чудо она становится видимой.
Что происходит непонятно, отсылать в СТП там может этого явления не проявиться.

6o6auko

Если проблема проявляется не у всех, видимо, все дело в железе...

Ash_wooD

Цитата: VIO от 12.08.19, 07:27:10
Такая же проблема существует и в 17-ом Компасе.
После обновления пакета 10-х "Окон" перестают иногда отображаться сборки, на экране её нет, а на вторичном изображении через закладки видно.
Может дрова видюхи может ещё что.
Научился бороться с этим, следующим образом, закрываю не отображаемую сборку, и открываю любой чертеж, фрагмент он отображается полностью.
После запускаю проблемную сборку, и о чудо она становится видимой.
Что происходит непонятно, отсылать в СТП там может этого явления не проявиться.

Закрыванием/открыванием у меня тоже лечится, но закрывать каждые 5 минут это как то перебор. Я бы тоже подумал на драйвера если бы не неработающая команда сдвиг и не фокус вида на начале координат

VIO

Нет мне достаточно один раз перезагрузить, после работает нормально.

Vitalij Lysanov

Если проблема отображения в сборке связана с неправильным заданием осей координат, по которым вставляется деталь или сборка. есть один признак.

Если присмотреться, на месте сборки должна появиться линия.

Пример из темы
https://forum.ascon.ru/index.php/topic,32279.msg262015.html#msg262015
Еле нашел отрезок. Цилиндр движется влево и вниз и когда цилиндр пропадает, в направлении -Y появляется зеленая линия.
Линия должна быть длиннее, но она сливается с осью координат.

На другом примере виднее
https://docs.google.com/document/d/1puM9SxDXwv02DadG2iV78mxSZFUWOZtVl2Au4_mwHK8/edit
На половине поворота балки, балка пропадает и появляется линия

Это все неправильное задание векторов для осей координат.
Два вектора должны быть ненулевые и ортогональные.

Без программы, в штатном функционале, все равно происходит расчет векторов.

Функции в частном случае могут иметь нулевое значение

Есть проблема поворотов ровно на 90 градусов.
И то что есть различия в отображении на предварительном просмотре и при добавлении детали, только подтверждает, что проблема с осями и что то связанное с поворотом на 90 градусов.
На предварительном просмотре включается другая программа и она по другому рассчитывает повороты.


Если бы было просто, уже бы сделали.

Если перед отображение отслеживать вектора осей на ортогональность, и на отличие от нуля, это самому себе указывать на ошибки, которые на данном этапе невозможно исправить