Компас v9: пропадает связь с ключом

Автор Тимофей113, 23.06.17, 13:57:44

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

Тимофей113

Добрый день! Такая проблема: есть небольшая одноранговая сеть в несколько компов, с виндой хр и 7. На всех компах установлен Компас v9 и на одном из них (с виндой ХР) стоит сетевой ключ и раздает лицензии. Сетевой ключ установлен по умолчанию (NetHASP), как и компас - без настроек. Интернет работает у всех через впн соединение, так вот когда пользователь подключается к интернету, с компа где установлена 7 винда пропадает связь с ключом на этом компе и вылетает ошибка 15, хотя доступ есть к компу с ключом. Там где установлена ХР, при подключении интернета ничего не происходит, компас работает нормально и лицензию получает.

Starik

Скорее всего у Вас такой древний хасп, что седьмую винду он попросту в полном объеме не поддерживает. А с ХР работает нормально. Попробуйте обратиться в СТП. Девятый компас они, правда, с поддержки давно сняли, но это касается только исправления ошибок в самом компасе. Может дадут подходящие драва для ключа. :um:

GL_E

Цитата: Тимофей113 от 23.06.17, 13:57:44
когда пользователь подключается к интернету, с компа где установлена 7 винда пропадает связь с ключом на этом компе и вылетает ошибка 15, хотя доступ есть к компу с ключом. Там где установлена ХР, при подключении интернета ничего не происходит, компас работает нормально и лицензию получает.


Это какие то проблемы с драйвером ключа. На некоторых машинах драйвер почему то не понимает куда девается ключ, если сетей больше 1.
попробуйте обновить драйвер ключа. их можно скачать на сайте производителей ключей.


---
PS
у меня такое на XP было (правда не с КОМПАСОМ), обновился на 7-ку + новые дрова ключей и все стало нормально.

Тимофей113

Попробовал все дрова, какие нашел (https://safenet-sentinel.ru/helpdesk/download-space/#tabs-3). Не помогает. В СТП пока не писал, ПО покупали давно, поддержка уже закончилась. Сейчас это не сильно мешает, но когда будет переход на 10 винду, то проблема уже будет более актуальна.

Starik

Под поддержкой в данном случае понимается исправление ошибок и внесение изменений. На ключи и консультации это не распространяется. Так мне объясняли в СТП.

Chipollino

Цитата: Тимофей113 от 23.06.17, 13:57:44
Сетевой ключ установлен по умолчанию (NetHASP), как и компас - без настроек.
...
Там где установлена ХР, при подключении интернета ничего не происходит, компас работает нормально и лицензию получает.


Нормально работает на всех ХР или только там где ключ вставлен?

Попробуйте в настройках локальных компов изменить broadcast поиск на указание IP или сетевого имени компа с ключом.

Тимофей113

Цитата: Starik от 29.06.17, 14:25:36
Под поддержкой в данном случае понимается исправление ошибок и внесение изменений. На ключи и консультации это не распространяется. Так мне объясняли в СТП.

Попозже попробую написать.
Цитата: Chipollino
Нормально работает на всех ХР или только там где ключ вставлен?
Попробуйте в настройках локальных компов изменить broadcast поиск на указание IP или сетевого имени компа с ключом.

На всех компах где ХР компас работает хорошо, ключ видят с подключением к инету и без.
Не работает только на 7 виндах при подключении к инету (ВПН соединение). Если к инету не подключаться, то все работает хорошо. Попробую прописать айпишник ключа в настройках.

Тимофей113

Цитата: Chipollino от 29.06.17, 14:49:40
Нормально работает на всех ХР или только там где ключ вставлен?

Попробуйте в настройках локальных компов изменить broadcast поиск на указание IP или сетевого имени компа с ключом.


Всем огромное спасибо, в особенности Chipollino! Выключил в Нетхаспе broadcast, прописал IP компа с ключом и включил режим работы протокол TCP/IP. Все заработало. Раньше пробовал айпишник прописывать, только broadcast не отключал, может в этом дело было и плюс дрова еще.

Chipollino

Про драйвера не знаю, может и в них дело, но broadcast это широковещательный запрос всем устройствам в сети с ожиданием ответа от подходящего. Скорее всего при включении VPN приоритетом становилась именно она и, не получив ответа там, служба hasp просто не искала в локальном подключении выдавая ошибку.