Проблема с пользовательскими моделями для библиотеки ТХ

Автор EvGeNy_T_GrEeCk, 22.03.17, 22:13:09

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

EvGeNy_T_GrEeCk

22.03.17, 22:13:09 Последнее редактирование: 16.08.17, 09:14:23 от Starik
При создание нового пользовательского элемента программа стала выдавать следующее сообщение. Есть ли какое то решение проблемы с сохранением моделей, уже очень много создано.

koav

04.04.17, 09:18:35 #1 Последнее редактирование: 04.04.17, 14:07:51 от koav
Добрый день!
Какие-то действия вы совершали операционной системой или КОМПАС?

Для работы с пользовательскими элементами требуется установленный .net версии не ниже 4.0.0.
Возможно Вы удалили .net или другое приложение загружает его и блокирует раньше чем Технология:ТХ.
Я - QA!

Lexsound

Не могу создать пользовательский элемент Технологии ТХ в Компас 16.2. Ошибка "Команда не может быть выполнена"

Lexsound

Добрый день! Пользуюсь библиотекой Технология ТХ и до недавнего времени мог создать свои библиотечные компоненты. Теперь я не могу создавать пользовательские элементы в Технологии ТХ пишет "Команда не может быть выполнена". Что делать? Информация по системе: Компас 16.1 (был 16.0), Windows 7.

kamos

Цитата: Lexsound от 16.08.17, 08:25:26
Добрый день! Пользуюсь библиотекой Технология ТХ и до недавнего времени мог создать свои библиотечные компоненты. Теперь я не могу создавать пользовательские элементы в Технологии ТХ пишет "Команда не может быть выполнена". Что делать? Информация по системе: Компас 16.1 (был 16.0), Windows 7.

Если есть возможность обратиться в техподдержку, то лучше туда, если нет, то стандартные пути:
1) удалить конфигурационные файлы
2) почистить папку temp
3)переустановить .net
4)через панель управления запустить исправление установки компаса


kamos

в папке %appdata%\Ascon\KOMPAS-3D\16.1\aec\EngSysLogs
лежит лог, если его сюда выложите  - попробую помочь, в идеале сделать так:
удалить всю папку по этому пути %appdata%\Ascon\KOMPAS-3D\16.1
запустить библиотеку получить сообщение об ошибке и после этого забрать лог и прислать его

Lexsound


kamos

1) Проверьте наличие и версию файла C:\Program Files\ASCON\KOMPAS-3D v16.1\Libs\Floorplan\EsUIContainer.dll
2) Укажите версию .net
3) Проверьте, что у вас есть доступ к папке C:\Users\имя пользователя\Documents\ASCON\Kompas-3D\16.0\AEC\Пользовательские элементы

Tipikon

Здравствуйте, при нажатии на кнопку "Создать пользовательсктй элемент" панели "Технология: ТХ" появляется окно с сообщением "Не удалось запустить команду редактирования пользовательских элементов. Смотри log-файл".

в log-файле написано:
09:27:24: ERR: Не смогли получить провайдер для редактирования базы

установлен .NET 4.7
папка "C:\Users\имя пользователя\Documents" пустая
версия файла C:\Program Files\ASCON\KOMPAS-3D v16.0\Libs\Floorplan\EsUIContainer.dll - 16.0.0.7328
админских прав нет

подскажите пожалуйста как исправить
спасибо

kamos

Цитата: Tipikon от 05.06.18, 09:57:49
Здравствуйте, при нажатии на кнопку "Создать пользовательсктй элемент" панели "Технология: ТХ" появляется окно с сообщением "Не удалось запустить команду редактирования пользовательских элементов. Смотри log-файл".

в log-файле написано:
09:27:24: ERR: Не смогли получить провайдер для редактирования базы

установлен .NET 4.7
папка "C:\Users\имя пользователя\Documents" пустая
версия файла C:\Program Files\ASCON\KOMPAS-3D v16.0\Libs\Floorplan\EsUIContainer.dll - 16.0.0.7328
админских прав нет

подскажите пожалуйста как исправить
спасибо


Для начала стоит установить все доступные обновления для 16 версии, а вообще лучше все-таки в техподдержку обратиться
И еще проверьте нет ли "C:\Users\имя пользователя\Documents" в этом адресе кириллицы в пути (в частности в имени пользователя, была когда-то проблема с кодировкой)

Positive

Цитата: kamos от 05.06.18, 11:20:18
Для начала стоит...



Чтобы не плодить темы... В приложении "Технология:ТХ" создаю пользовательский элемент, заполняю графы во вкладках "оформление" и "параметры",  этот элемент впоследствии  отображается в спецификации, но не отображается в ведомости трубопроводов. В чём может быть причина?  Устал уже перелопачивать справку... Вроде бы вы хорошо разбираетесь  в данном приложении и, возможно, сможете помочь в устранении этого пробела в моих знаниях и умениях. Заранее спасибо!

kamos

У меня тоже не попадает, похоже на ошибку в приложении, обратитесь в ТП, выглядит как совсем какая-то мелочь, обычно такое быстро правят

Positive

[
Цитата: kamos от 10.01.19, 15:25:58
У меня тоже не попадает, похоже на ошибку в приложении, обратитесь в ТП, выглядит как совсем какая-то мелочь, обычно такое быстро правят


А ранее они у Вас в ведомость попадали? У меня 18 компас. Знакомые попробовали в 17 компасе - говорят, что у них тоже не попадает, хотя они ни разу в ТХ не разбираются... Всё же создал тему -  вдруг кто обратит внимание из сведущих.

kamos

Я ведомостью трубопроводов только ГОСТовскую использовал, а ее в Компасе нет, поэтому делал в ручную.
Цитата: Positive от 23.01.19, 14:36:56
[
вдруг кто обратит внимание из сведущих.

А зачем надеяться на "вдруг"? Как-то представители разработки упоминали, что отсутствие обратной связи от пользователей это проблема.



kamos

Покопался в настройках ведомости
Если залезть в редактирование стиля и подключить отображение пользовательских элементов, то они начинают попадать в ведомость

kamos