Новичок просит помощи у знающих

Автор 1000box, 30.03.05, 18:04:07

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

МАx

Серж, там ещё дополнительно для каждого ГОСТа (v 1.4) нужно скачивать отдельный модуль. Впрочем, у меня та же проблема: 1.3 работает, а 1.4 не могу даже подключить - выдаёт ошибку Error 126 и говорит "неверная структура файла". Версия компаса 7 (без креста). Может эта библиотека под версию 7+, и я стучусь головой об стену?

fil

У меня номер пишет, что произошла ошибка и приложение будет закрыто и все.
Пробовал и с К7 и с К7+.

Sabahs

Извиняюсь, действительно была ошибка в импортировании универсальной функции отрисовки из DLL. Библиотеку я обновил остальные файлы в порядке. Спасибо Fil помощь в обнаружении глюков.

fil

Скачал, но результат такой же.

Sabahs

Вы писали, что библиотека расположена:
C:\Program Files\ASCON\KOMPAS-3D V7\Libs\podsipnik3D\Podsipnik3D.rtw
Значит папка BIN должна быть расположена:
C:\Program Files\ASCON\KOMPAS-3D V7\Libs\podsipnik3D\bin\
В ней обязательно должны быть следующие файлы, причем v1.4 от версии 1.3 не подойдут, вызовут ошибку из-за изменения формата записи и компас вылетит:
type.pbd
GOST_8338-75.pbd
GOST_831-75.pbd
GOST_7872-75.pbd
GOST_7634-75.pbd
GOST_7260-81.pbd
GOST_6874-75.pbd
GOST_5721-75.pbd
GOST_5720-75.pbd
GOST_5377-79.pbd
GOST_4657-82.pbd
GOST_333-79.pbd
Остальные файлы DLL модулей на работоспособность библиотеки не влияют и добавляются по мере необходимости ГОСТов.
Если у Вас все располагается так, то тогда не знаю в чем причина, я данную версию проверял по полной программе.

fil

Все расположено именно так, но не работает.
Жаль, откатился на версию 1.3.

Sabahs

Библиотека под К7 без обновлений, т.к на демоверсию обновление не поставиш.

1000box

Все так и сделал. Все равно при попытке подключить библиотеку Компас выдает ошибку. Может это связанно с тем, что у меня самая последняя версия "Компас 3D V7 Плюс" с обновлением SP1?

fil

ЦитироватьБиблиотека под К7 без обновлений, т.к на демоверсию обновление не поставиш.
Тогда все понятно.
У меня установлены все обновления.
Однако, версия 1.3 работает и с обновлениями.

Sabahs

Библиотека версии 1.4 чувствительнее к изменениям, чем версия 1.3 т.к. сама состоит из нескольких модулей и настраивается на работу полностью динамически.
В ближайшее время выйдет библиотека под 7+, т.ч. немного подождите.

Sabahs

Когда Вы удаляли версию 1.3, обязательно необходимо запустить файл UninstallP3D.exe или удалить в реестре ключ HKEY_CURRENT_USER\Software\Podsipnik3D.

fil

ЦитироватьБиблиотека версии 1.4 чувствительнее к изменениям, чем версия 1.3 т.к. сама состоит из нескольких модулей и настраивается на работу полностью динамически.
В ближайшее время выйдет библиотека под 7+, т.ч. немного подождите.
А под 8н не планируешь?
Вообще то давно не обновлялся сайт.

ingeneer


Sabahs

Скорее всего завтра выложу под 8-ку.

Sabahs

Выложена версия подшипников 3D V1.4 для Компас V8.
См. на сайте http://mariupolsapr.4ertim.com/

fil

Просьба перезалить ГОСТ 5720-75  - архив битый, качал несколько раз.

Sabahs

Спасибо! Архив действительно битый.
Файл исправлен, можете качать.

Sabahs

Попробуйте сделать следующее перед подключением библиотеки.
Когда Вы удаляли версию 1.3, обязательно необходимо запустить файл UninstallP3D.exe или удалить в реестре ключ HKEY_CURRENT_USER\Software\Podsipnik3D.