Проблема с загрузкой файлов в ЛОЦМАН

Автор rain, 01.09.11, 08:36:57

« предыдущая - следующая »

0 Пользователей и 1 гость просматривают эту тему.

rain

Здравствуйте!
возникла такая проблема с лоцманом V10.
в БД была сборочная единица ...43 А4 СБ, в ней несколько исполнений ...43-01 А4 СБ, ...43-02 А4 СБ и т.д.
в эти сборочные единицы были загружены 3D-модели сборок и из них извлечена информация, вследствие чего автоматически построилась структура всей сборки. ну так вот мы делаем на предприятии.
так вот, после обнаруженной ошибки я всю эту сборку удалил, все сохранил, вернул, с рабочего диска все удалил. седня открываю лоцман, создаю все заново, но при подпытке загрузить 3D-модель сборки лоцман пишет, что файл с таким именем уже зарегистрирован в БД.
Собственно вопрос: где может храниться эта информация о файлах, которых уже нет и не надо, и как ее удалить?

Muk

Может Вы просто родительскую связь у сборки удалили? Поищите сборку в неприменненных объектах через соответствующий отчет.

rain

спасибо! нашел эти сборки в непримененных объектах. только теперь не разберусь, что с ними делать?

Muk

Либо привязать обратно и, заменив файл, получить из модели состав. Или удалить сборку (открыть в новом окне, взять в работу и т.д.), а затем создать снова.

rain

а чтобы удалить, открыть сборку в новом окне можно прямо из отчета? или как вообще это делается?

Muk

Не помню уже. Там по правой кнопке нет команды? В крайнем случае поиском по типу и обозначению. А там точно есть "Открыть в новом окне".

rain

спасибо Вам огромное!!! все получилось!)) а то работа простаивала

ALEX_78

в таких случаях надо не просто удалять сборку а удалять со всеми вложенными документами.
иначе бывает что система удаляет, но остаются детали которые ни к одной сборочной единице не относятся.
было похожее дело, когда при создании детали с определенным обозначением выдает что такое уже имя зарегистрировано но самого объекта нет в базе данных.
можно попробовать извращенным способом создать сборку или деталь заменив например русскую букву "С" на английскую "С" в обозначении сборочной единицы. но это конечно же не выход.....
у меня юзвери таких левых деталей и сборок уже сделали штук 20..... после неправильного удаления.

rain

я просто тока начал в лоцмане работать, поэтому и занимался извратом типа замены букв и удаления пробелов)) ну щас вроде немного въехал, делаю более-менее правильно